Avisar de contenido inadecuado

52 EJERCICIOS pseudocódigo! RESUELTOS...

{
}

52 EJERCICIOS pseudocódigo! RESUELTOS...

 

1.-Hacer un pseudocodigo que imprima los numeros del 1 al 100.

 

PROGRAMA contador1

ENTORNO:

   c <- 0

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS c < 101 HACER

      ESCRIBIR c

      c <- c + 1

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

2.-Hacer un pseudocodigo que imprima los numeros del 100 al 0, en orden

decreciente.

 

PROGRAMA contador2

ENTORNO:

   c <- 100

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS c <= 0 HACER

      ESCRIBIR c

      c <- c - 1

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

3.-Hacer un pseudocodigo que imprima los numeros pares entre 0 y 100.

 

PROGRAMA pares

ENTORNO:

   c <- 2

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS c < 101 HACER

      ESCRIBIR c

      c <- c + 2

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

4.-Hacer un programa que imprima la suma de los 100 primeros numeros.

 

PROGRAMA suma

ENTORNO:

   c <- 1

   suma <- 0

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS c <= 100 HACER

      suma <- suma + c

      c <- c + 1

   FINMIENTRAS

   ESCRIBIR "La suma de los 100 primeros n£meros es: "

   ESCRIBIR suma

FINPROGRAMA

 

--------------------------------------------------------------------------

 

5.-Hacer un pseudocódigo que imprima los numeros impares hasta el 100 y que

imprima cuantos impares hay.

 

PROGRAMA impares

ENTORNO:

   c <- 1

   son <- 0

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS c < 100

      ESCRIBIR c

      c <- c + 2

      son <- son + 1

   FINMIENTRAS

   ESCRIBIR "El n£mero de impares: "

   ESCRIBIR son

FINPROGRAMA

 

--------------------------------------------------------------------------

 

6.-Hacer un pseudocodigo que imprima todos los numeros naturales que hay

desde la unidad hasta un numero que introducimos por teclado.

 

PROGRAMA natural

ENTORNO:

   i <- 0

   n <- 0

ALGORITMO:

   Borrar_pantalla( )

   ESCRIBIR "Introduce un n£mero: "

   LEER n

   MIENTRAS i < n HACER

      i <- i + 1

      ESCRIBIR i

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

7.-Introducir tantas frases como queramos y contarlas.

 

PROGRAMA frases

ENTORNO:

   res <- "S"

   frase <- Espacios( 30 )

   c <- 0

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS res = "S" HACER

      ESCRIBIR "Frase: "

      LEER frase

      c <- c + 1

      ESCRIBIR "Deseas introducir m s frases (S/N): "

      LEER res

   FINMIENTRAS

   ESCRIBIR "El n£mero de frases introducidas son: "

   ESCRIBIR c

FINPROGRAMA

 

 

 

 

 

 

 

 

 

 

--------------------------------------------------------------------------

 

8.-Hacer un pseudocodigo que solo nos permita introducir S o N.

 

PROGRAMA sn

ENTORNO:

   res <- " "

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS res <> "S" Y res <> "N" HACER

      ESCRIBIR "Introduce S o N"

      LEER res

      res <- Convertir_may£sculas( res )

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

9.-Introducir un numero por teclado. Que nos diga si es positivo o negativo.

 

PROGRAMA signo

ENTORNO:

   num <- 0

ALGORITMO:

   Borrar_pantalla( )

   ESCRIBIR "Introduce un n£mero: "

   LEER num

   SI num >= 0 ENTONCES

      ESCRIBIR "es positivo"

   SINO

      ESCRIBIR "es negativo"

   FINSI

FINPROGRAMA

 

--------------------------------------------------------------------------

 

10.-Introducir un numero por teclado. Que nos diga si es par o impar.

 

PROGRAMA paridad

ENTORNO:

   num <- 0

ALGORITMO:

   Borrar_pantalla( )

   ESCRIBIR "Introduce un n£mero: "

   LEER num

   SI num = int( num / 2 ) * 2 ENTONCES

      ESCRIBIR "es par"

   SINO

      ESCRIBIR "es impar"

   FINSI

FINPROGRAMA

 

--------------------------------------------------------------------------

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

11.-Imprimir y contar los multiplos de 3 desde la unidad hasta un numero que

introducimos por teclado.

 

PROGRAMA multiplo3

ENTORNO:

   i <- 3

   n <- 0

   c <- 0

ALGORITMO:

   Borrar_pantalla( )

   ESCRIBIR "N£mero: "

   LEER n

   MIENTRAS i <= n HACER

      SI i = int( i / 3 ) * 3 ENTONCES

         ESCRIBIR i

         c <- c + 1

      FINSI

      i <- i + 1

   FINMIENTRAS

   ESCRIBIR "El n£mero de m£ltiplos de 3 son: "

   ESCRIBIR c

FINPROGRAMA

 

--------------------------------------------------------------------------

 

12.-Hacer un pseudocodigo que imprima los numeros del 1 al 100. Que calcule la

suma de todos los numeros pares por un lado, y por otro, la de todos los

impares.

 

PROGRAMA par_impar

ENTORNO:

   i <- 1

   sumapar <- 0

   sumaimp <- 0

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS i < 101 HACER

      SI i = int( i / 2 ) * 2 ENTONCES

         sumapar <- sumapar + i

      SINO

         sumaimp <- sumaimp + i

      FINSI

      i <- i + 1

   FINMIENTRAS

   ESCRIBIR "La suma de los pares es: "

   ESCRIBIR sumapar

   ESCRIBIR "La suma de los impares es: "

   ESCRIBIR sumaimp

FINPROGRAMA

 

--------------------------------------------------------------------------

 

13.-Imprimir y contar los numeros que son multiplos de 2 o de 3 que hay entre

1 y 100.

PROGRAMA multiplo_2_3

ENTORNO:

   i <- 1

   c <- 0

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS i < 101 HACER

      SI i = int( i / 2 ) * 2 O i = int( i / 3 ) * 3 ENTONCES

         c <- c + 1

         ESCRIBIR i

      FINSI

      i <- i + 1

   FINMIENTRAS

   ESCRIBIR "El n£mero de m£ltiplos es de: "

   ESCRIBIR c

FINPROGRAMA

 

--------------------------------------------------------------------------

 

14.-Hacer un pseudocodigo que imprima el mayor y el menor de una serie de

cinco numeros que vamos introduciendo por teclado.

 

PROGRAMA mayor_menor

ENTORNO:

   con <- 0

   n <- 0

   maximo <- 0

   minimo <- 99999

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS con <= 5 HACER

      ESCRIBIR "N£mero: "

      LEER n

      SI n > maximo ENTONCES

         maximo = n

      FINSI

      SI n < minimo ENTONCES

         minimo <- n

      FINSI

      con <- con + 1

   FINMIENTRAS

   ESCRIBIR "El mayor de los n£meros es: "

   ESCRIBIR maximo

   ESCRIBIR "El menor de los n£meros es: "

   ESCRIBIR minimo

FINPROGRAMA

 

--------------------------------------------------------------------------

 

15.-Introducir dos numeros por teclado. Imprimir los numeros naturales que

hay entre ambos numeros empezando por el m s pequeño, contar cuantos hay y

cuantos de ellos son pares. Calcular la suma de los impares.

PROGRAMA par_impar

ENTORNO:

   num1 <- 0

   num2 <- 0

   aux <- 0

   son <- 0

   pares <- 0

   sumaimpa <- 0

ALGORITMO:

   Borrar_pantalla( )

   ESCRIBIR "N£mero: "

   LEER num1

   ESCRIBIR "N£mero: "

   LEER num2

   SI num1 > num2 ENTONCES

      aux <- num1

      num1 <- num2

      num2 <- aux

   FINSI

   MIENTRAS num1 >= num2 HACER

      ESCRIBIR num1

      son <- son + 1

      SI num1 = int( num1 / 2 ) * 2 ENTONCES

         pares <- pares + 1

      SINO

         sumaimpa <- sumaimpa + num1

      FINSI

      num1 <- num1 + 1

   FINMIENTRAS

   ESCRIBIR "N£meros visualizados: "

   ESCRIBIR son

   ESCRIBIR "Pares hay: "

   ESCRIBIR pares

   ESCRIBIR "La suma de los impares es: "

   ESCRIBIR sumaimpa

FINPROGRAMA

 

--------------------------------------------------------------------------

TEMA 2

--------------------------------------------------------------------------

Bucles anidados y subprogramas

--------------------------------------------------------------------------

 

16.-Imprimir diez veces la serie de numeros del 1 al 10.

 

PROGRAMA diez

ENTORNO:

   serie <- 0

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS serie <= 10 HACER

      numero <- 1

      MIENTRAS numero <= 10 HACER

         ESCRIBIR numero

         numero <- numero + 1

      FINMIENTRAS

      serie <- serie + 1

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

17.-Imprimir, contar y sumar los multiplos de 2 que hay entre una serie de

numeros, tal que el segundo sea mayor o igual que el primero.

 

PROGRAMA multiplo2

ENTORNO:

   res <- "S"

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS res = "S" HACER

      c <- 0

      sum <- 0

      num1 <- 0

      num2 <- -999

      ESCRIBIR "N£mero: "

      LEER num1

      ESCRIBIR "N£mero mayor que el anterior"

      MIENTRAS num1 >= num2 HACER

         LEER num2

      FINMIENTRAS

      num1 <- num1 + 1

      MIENTRAS num1 <= num2 - 1 HACER

         SI num1 = int( num1 / 2 ) * 2 ENTONCES

            ESCRIBIR num1

            c <- c + 1

            sum <- sum + num1

         FINSI

         num1 <- num1 + 1

      FINMIENTRAS

      ESCRIBIR "N£mero de m£ltiplos de 2: "

      ESCRIBIR c

      ESCRIBIR "Su suma es: "

      ESCRIBIR sum

      res <- Espacios( 1 )

      MIENTRAS res <> "S" Y res <> "N" HACER

         ESCRIBIR "Otra serie de n£meros (S/N): "

         LEER res

         res <- Convertir_may£sculas( res )

      FINMIENTRAS

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

18.-Hacer un pseudocodigo que cuente las veces que aparece una determinada

letra en una frase que introduciremos por teclado.

 

PROGRAMA letra

ENTORNO:

   frase <- Espacios( 30 )

   letra <- Espacios( 1 )

   longitud <- 0

   a <- 0

   res <- "S"

ALGORITMO:

   MIENTRAS res = "S" HACER

      Borrar_pantalla( )

      ESCRIBIR "Introduce una frase: "

      LEER frase

      longitud <- Hallar_longitud( frase )

      i <- 1

      ESCRIBIR "Letra a buscar: "

      LEER letra

      MIENTRAS i <= longitud HACER

         SI letra = Caracter( frase, i, 1 ) ENTONCES

            a <- a + 1

         FINSI

         i <- i + 1

      FINMIENTRAS

      Borrar_pantalla( )

      ESCRIBIR "El n£mero de veces que aparece la letra "

      ESCRIBIR letra

      ESCRIBIR " en la frase "

      ESCRIBIR frase

      ESCRIBIR " es de "

      ESCRIBIR a

      res <- Espacios( 1 )

      MIENTRAS res <> "S" Y res <> "N" HACER

         ESCRIBIR "Desea introducir m&aacute;s frases (S/N): "

         LEER res

         res <- Convertir_may£sculas( res )

      FINMIENTRAS

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

19.-Hacer un pseudocodigo que simule el funcionamiento de un reloj digital y

que permita ponerlo en hora.

 

PROGRAMA reloj

ENTORNO:

   horas <- 0

   minutos <- 0

   segundos <- 0

   res <- "S"

ALGORITMO:

   Borrar_pantalla( )

   ESCRIBIR "Horas: "

   LEER horas

   ESCRIBIR "Minutos: "

   LEER minutos

   ESCRIBIR "Segundos: "

   LEER segundos

   MIENTRAS res = "S" HACER

      MIENTRAS horas < 24 HACER

         MIENTRAS minutos < 60 HACER

            MIENTRAS segundos < 60 HACER

               ESCRIBIR horas

               ESCRIBIR minutos

               ESCRIBIR segundos

               segundos <- segundos + 1

            FINMIENTRAS

            minutos <- minutos + 1

            segundos <- 0

         FINMIENTRAS

         horas <- horas + 1

         minutos <- 0

      FINMIENTRAS

      horas <- 0

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

20.-Calcular el factorial de un numero, mediante subprogramas.

 

PROGRAMA factorial

ENTORNO:

   res <- "S"

ALGORITMO:

   MIENTRAS res = "S" HACER

      Borrar_pantalla( )

      factorial <- 1

      ESCRIBIR "N£mero: "

      LEER numero

      SI numero < 0 ENTONCES

         ESCRIBIR "No tiene factorial"

      SINO

         HACER Calculos

      FINSI

      HACER Mas

   FINMIENTRAS

FINPROGRAMA

------------------------------

SUBPROGRAMA Calculos

   MIENTRAS numero > 1 HACER

      factorial <- factorial * numero

      numero <- numero - 1

   FINMIENTRAS

   HACER Imprimir

FINSUBPROGRAMA

------------------------------

SUBPROGRAMA Mas

   res <- " "

   MIENTRAS res <> "S" Y res <> "N" HACER

      ESCRIBIR "Desea calcular m&aacute;s factoriales (S/N): "

      LEER res

      res <- Convertir_may£sculas( res )

   FINMIENTRAS

FINSUBPROGRAMA

------------------------------

SUBPROGRAMA Imprimir

   ESCRIBIR "Su factorial es: "

   ESCRIBIR factorial

FINSUBPROGRAMA

 

 

--------------------------------------------------------------------------

 

 

 

 

 

 

 

 

 

 

 

 

 

 

21.-Hacer un programa que calcule independientemente la suma de los pares y

los impares de los numeros entre 1 y 1000, utilizando un switch.

 

PROGRAMA suma

ENTORNO:

   par <- 0

   impar <- 0

   sw <- 0

   i <- 1

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS i <= 1000 HACER

      SI sw = 0 ENTONCES

         impar <- impar + i

         sw <- 1

      SINO

         par <- par + i

         sw <- 0

      FINSI

      i <- i + 1

   FINMIENTRAS

   ESCRIBIR "La suma de los pares es: "

   ESCRIBIR par

   ESCRIBIR "La suma de los impares es: "

   ESCRIBIR impar

FINPROGRAMA

 

--------------------------------------------------------------------------

TEMA 3

--------------------------------------------------------------------------

Presentacion en pantalla y cabeceras

--------------------------------------------------------------------------

 

22.-Introducir una frase por teclado. Imprimirla cinco veces en filas

consecutivas, pero cada impresion ir  desplazada cuatro columnas hacia la

derecha.

 

PROGRAMA frase

ENTORNO:

   frase <- Espacios( 30 )

ALGORITMO:

   Borrar_pantalla( )

   EN 5,15 ESCRIBIR "Frase: "

   EN 5,22 LEER frase

   fi <- 8

   co <- 15

   veces <- 0

   MIENTRAS veces <= 5 HACER

      EN fi,co ESCRIBIR frase

      veces <- veces + 1

      co <- co + 4

      fi <- fi + 1

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

23.-Hacer un pseudocodigo que imprima los n£meros del 0 al 100, controlando

las filas y las columnas.

 

PROGRAMA numeros

ENTORNO:

   c <- 0

ALGORITMO:

   Borrar_pantalla( )

   EN 5,20 ESCRIBIR "Los n£meros del 0 al 100 son: "

   fi <- 7

   col <- 5

   MIENTRAS c < 101 HACER

      EN fi,col ESCRIBIR c

      c <- c + 1

      col <- col + 4

      SI col > 75 ENTONCES

         fi <- fi + 2

         col <- 5

      FINSI

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

24.-Comprobar si un numero mayor o igual que la unidad es primo.

 

PROGRAMA primo

ENTORNO:

   res <- "S"

ALGORITMO:

   MIENTRAS res = "S" HACER

      Borrar_pantalla( )

      numero <- 0

      sw <- 0

      MIENTRAS numero < 1 HACER

         EN 8,10 ESCRIBIR "N£mero: "

         EN 8,18 LEER numero

      FINMIENTRAS

      i <- numero - 1

      MIENTRAS i > 1 Y sw <> 1 HACER

         SI numero = Int( numero / i ) * i ENTONCES

            sw = 1

         SINO

            i <- i - 1

         FINSI

      FINMIENTRAS

      SI sw = 1 ENTONCES

         EN 10,10 ESCRIBIR "no es primo"

      SINO

         EN 10,10 ESCRIBIR "s¡ es primo"

      FINSI

      HACER Mas

   FINMIENTRAS

FINPROGRAMA

------------------------------

SUBPROGRAMA Mas

   res <- " "

   MIENTRAS res <> "S" Y res <> "N" HACER

      ESCRIBIR "Desea introducir m s n£meros (S/N): "

      LEER res

      res <- Convertir_mayusculas( res )

   FINMIENTRAS

FINSUBPROGRAMA

 

--------------------------------------------------------------------------

 

25.-Introducir un numero menor de 5000 y pasarlo a numero romano.

 

PROGRAMA romano

ENTORNO:

   res <- "S"

ALGORITMO:

   MIENTRAS res = "S" HACER

      Borrar_pantalla( )

      num <- 0

      MIENTRAS num < 1 O num > 5000 HACER

         EN 8,10 ESCRIBIR "N£mero: "

         EN 8,18 ESCRIBIR num

      FINMIENTRAS

      col <- 15

      MIENTRAS num >= 1000 HACER

         EN 15,col ESCRIBIR "M"

         num <- num - 1000

         col <- col + 1

      FINMIENTRAS

      SI num >= 900 ENTONCES

         EN 15,col ESCRIBIR "CM"

         num <- num - 900

         col <- col + 2

      FINSI

      SI num >= 500 ENTONCES

         EN 15,col ESCRIBIR "D"

         num <- num - 500

         col <- col + 1

      FINSI

      MIENTRAS num >= 100 HACER

         EN 15,col ESCRIBIR "C"

         num <- num - 100

         col <- col + 1

      FINMIENTRAS

      SI num >= 90 ENTONCES

         EN 15,col ESCRIBIR "XC"

         num <- num - 90

         col <- col + 2

      FINSI

      SI num >= 50 ENTONCES

         EN 15,col ESCRIBIR "L"

         num <- num - 50

         col <- col + 1

      FINSI

      SI num >= 40 ENTONCES

         EN 15,col ESCRIBIR "XL"

         num <- num - 40

         col <- col + 2

      FINSI

      MIENTRAS num >= 10 HACER

         EN 15,col ESCRIBIR "X"

         num <- num - 10

         col <- col + 1

      FINMIENTRAS

      SI num = 9 ENTONCES

         EN 15,col ESCRIBIR "IX"

         num <- num - 9

         col <- col + 2

      FINSI

      SI num >= 5 ENTONCES

         EN 15,col ESCRIBIR "V"

         num <- num - 5

         col <- col + 1

      FINSI

      SI num >= 4 ENTONCES

         EN 15,col ESCRIBIR "IV"

         num <- num - 4

         col <- col + 2

      FINSI

      MIENTRAS num > 0 HACER

         EN 15,col ESCRIBIR "I"

         num <- num - 1

         col <- col + 1

      FINMIENTRAS

      HACER Mas

   FINMIENTRAS

FINPROGRAMA

------------------------------

SUBPROGRAMA Mas

   res <- " "

   MIENTRAS res <> "S" Y res <> "N" HACER

      ESCRIBIR "Desea introducir m s n£meros (S/N): "

      LEER res

      res <- Convertir_mayusculas( res )

   FINMIENTRAS

FINSUBPROGRAMA

 

--------------------------------------------------------------------------

 

26.-Introducir una frase por teclado. Imprimirla en el centro de la pantalla.

 

PROGRAMA centro

ENTORNO:

   res <- "S"

   frase <- Espacios( 40 )

ALGORITMO:

   MIENTRAS res = "S" HACER

      Borrar_pantalla( )

      EN 5,15 ESCRIBIR "Frase: "

      EN 5,22 LEER frase

      EN 12,40 - Int( Longitud( frase ) / 2 ) ESCRIBIR frase

      HACER Mas

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

27.-Realizar la tabla de multiplicar de un numero entre 0 y 10.

 

PROGRAMA tabla

ENTORNO:

   num <- -1

ALGORITMO:

   HACER Numero

   Borrar_pantalla( )

   EN 5,10 ESCRIBIR "Tabla de multiplicar del n£mero: "

   EN 5,40 LEER num

   i <- 0

   fi <- 8

   MIENTRAS i <= 10 HACER

      EN fi,15 ESCRIBIR num

      EN fi,19 ESCRIBIR " * "

      EN fi,23 ESCRIBIR i

      EN fi,25 ESCRIBIR " = "

      EN fi,29 ESCRIBIR num * i

      fi <- fi + 1

      i <- i + 1

   FINMIENTRAS

FINPROGRAMA

------------------------------

SUBPROGRAMA Numero

   MIENTRAS num < 0 HACER

      Borrar_pantalla( )

      EN 10,25 ESCRIBIR "N£mero: "

      EN 10,33 LEER num

   FINMIENTRAS

FINSUBPROGRAMA

 

--------------------------------------------------------------------------

TEMA 4

--------------------------------------------------------------------------

Numeros aleatorios y menus

--------------------------------------------------------------------------

 

28.-Simular el lanzamiento de una moneda al aire e imprimir si ha salido cara

o cruz.

 

PROGRAMA moneda

ENTORNO:

   res <- "S"

ALGORITMO:

   MIENTRAS res = "S" HACER

      Borrar_pantalla( )

      SI Rnd( ) <= 0.5 ENTONCES

         EN 10,35 ESCRIBIR "Cara"

      SINO

         EN 10,35 ESCRIBIR "Cruz"

      FINSI

      HACER Mas

   FINMIENTRAS

FINPROGRAMA

------------------------------

SUBPROGRAMA Mas

   res <- Espacios( 1 )

   MIENTRAS res <> "S" Y res <> "N" HACER

      EN 20,30 ESCRIBIR "M s lanzamientos (S/N): "

      EN 20,57 LEER res

      res <- Convertir_mayusculas( res )

   FINMIENTRAS

FINSUBPROGRAMA

 

--------------------------------------------------------------------------

 

29.-Simular cien tiradas de dos dados y contar las veces que entre los dos

suman 10.

 

PROGRAMA dado

ENTORNO:

   c <- 0

   i <- 0

ALGORITMO:

   Borrar_pantalla( )

   MIENTRAS i < 101 HACER

      SI Int( Rnd( ) * 6 ) + Int( Rnd( ) * 6 ) + 2 = 10 ENTONCES

         c <- c + 1

      FINSI

      i <- i + 1

   FINMIENTRAS

   EN 10,20 ESCRIBIR "Las veces que suman 10 son: "

   EN 10,48 ESCRIBIR c

FINPROGRAMA

 

--------------------------------------------------------------------------

 

30.-Simular una carrera de dos caballos si cada uno tiene igual probabilidad

de ganar.

 

PROGRAMA caballos

ENTORNO:

   dibujo <- "****"

   col1 <- 4

   col2 <- 4

ALGORITMO:

   Borrar_pantalla( )

   EN 10,col1 ESCRIBIR dibujo

   EN 10,col2 ESCRIBIR dibujo

   MIENTRAS col1 <= 75 Y col2 <= 75 HACER

      SI Rnd( ) <= 0.5 ENTONCES

         EN 10,col1 ESCRIBIR Espacios( 4 )

         col1 <- col1 + 4

         EN 10,col1 ESCRIBIR dibujo

      SINO

         EN 12,col2 ESCRIBIR Espacios( 4 )

         col2 <- col2 + 4

         EN 12,col2 ESCRIBIR dibujo

      FINSI

   FINMIENTRAS

   EN 16,20 ESCRIBIR "El ganador es el caballo n£mero: "

   SI col1 >= 75 ENTONCES

      EN 16,54 ESCRIBIR "1"

   SINO

      EN 16,54 ESCRIBIR "2"

   FINSI

FINPROGRAMA

 

--------------------------------------------------------------------------

 

31.-Introducir dos nymeros por teclado y mediante un menu, calcule su suma, su

resta, su multiplicacion o su division.

 

PROGRAMA menu1

ENTORNO:

   op <- 0

ALGORITMO:

   EN 10,20 ESCRIBIR "N£mero: "

   EN 10,29 LEER n1

   EN 12,20 ESCRIBIR "N£mero: "

   EN 12,29 LEER n2

   MIENTRAS op <> 5 HACER

      op <- 0

      Borrar_pantalla( )

      EN 6,20 ESCRIBIR "Men£ de opciones"

      EN 10,25 ESCRIBIR "1.- Suma"

      EN 12,25 ESCRIBIR "2.- Resta"

      EN 14,25 ESCRIBIR "3.- Multiplicaci¢n"

      EN 16,25 ESCRIBIR "4.- Divisi¢n"

      EN 18,25 ESCRIBIR "5.- Salir del programa"

      EN 22,25 ESCRIBIR "Elija opci¢n: "

      EN 22,39 LEER op

      Borrar_pantalla( )

      HACER CASO

         CASO op = 1

            EN 10,20 ESCRIBIR "Su suma es: "

            EN 10,33 ESCRIBIR n1 + n2

            Pausa( )

         CASO op = 2

            EN 10,20 ESCRIBIR "Su resta es: "

            EN 10,33 ESCRIBIR n1 - n2

            Pausa( )

         CASO op = 3

            EN 10,20 ESCRIBIR "Su multiplicaci¢n es: "

            EN 10,33 ESCRIBIR n1 * n2

            Pausa( )

         CASO op = 4

            EN 10,20 ESCRIBIR "Su divisi¢n es: "

            EN 10,33 ESCRIBIR n1 / n2

            Pausa( )

      FINCASO

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

32.-Hacer un programa que nos permita introducir un numero por teclado y sobre

el se realicen las siguientes operaciones: comprobar si es primo, hallar

su factorial o imprimir su tabla de multiplicar.

 

PROGRAMA menu2

ENTORNO:

   op <- 0

ALGORITMO:

   EN 10,20 ESCRIBIR "N£mero: "

   EN 10,29 LEER n

   MIENTRAS op <> 4 HACER

      op <- 0

      Borrar_pantalla( )

      EN 6,30 ESCRIBIR "Men£ de opciones"

      EN 10,25 ESCRIBIR "1.- Comprobar si es primo"

      EN 12,25 ESCRIBIR "2.- Hallar su factorial"

      EN 14,25 ESCRIBIR "3.- Tabla de multiplicar"

      EN 16,25 ESCRIBIR "4.- Salir del programa"

      EN 22,25 ESCRIBIR "Elija opci¢n: "

      EN 22,39 LEER op

      HACER CASO

         CASO op = 1

            HACER Primo

         CASO op = 2

            HACER Factorial

         CASO op = 3

            HACER Tabla

      FINCASO

   FINMIENTRAS

FINPROGRAMA

------------------------------

SUBPROGRAMA Primo

   sw <- 0

   i <- n - 1

   MIENTRAS i > 1 Y sw <> 1 HACER

      SI n = Int( n / i ) * i ENTONCES

         sw <- 1

      SINO

         i <- i - 1

      FINSI

   FINMIENTRAS

   Borrar_pantalla( )

   SI sw = 1 ENTONCES

      EN 10,10 ESCRIBIR "no es primo"

   SINO

      EN 10,10 ESCRIBIR "s¡ es primo"

   FINSI

   Pausa( )

FINSUBPROGRAMA

------------------------------

SUBPROGRAMA Factorial

   fac <- 1

   Borrar_pantalla( )

   SI n < 0 ENTONCES

      EN 10,10 ESCRIBIR "No tiene factorial"

   SINO

      MIENTRAS n > 1 HACER

         fac <- fac * n

         n <- n - 1

      FINMIENTRAS

      EN 10,10 ESCRIBIR "Su factorial es: "

      EN 10,27 ESCRIBIR fac

   FINSI

   Pausa( )

FINSUBPROGRAMA

------------------------------

SUBPROGRAMA Tabla

   i <- 0

   fi <- 10

   Borrar_pantalla( )

   MIENTRAS i <= 10 HACER

      EN 8,10 ESCRIBIR "Tabla de multiplicar"

      EN fi,10 ESCRIBIR n

      EN fi,15 ESCRIBIR "*"

      EN fi,20 ESCRIBIR i

      EN fi,25 ESCRIBIR "="

      EN fi,30 ESCRIBIR n * i

      i <- i + 1

   FINMIENTRAS

   Pausa( )

FINSUBPROGRAMA

 

--------------------------------------------------------------------------

TEMA 4

--------------------------------------------------------------------------

Arrays unidimensionales

--------------------------------------------------------------------------

 

33.-Crear un array unidimensional de 20 elementos con nombres de personas.

Visualizar los elementos de la lista debiendo ir cada uno en una fila

distinta.

 

PROGRAMA nombres

ENTORNO:

   DIMENSIONA datos[ 20 ]

   i <- 1

ALGORITMO:

   Borrar_pantalla( )

   fi <- 10

   MIENTRAS i < 21 HACER

      EN fi,10 ESCRIBIR "Nombre: "

      EN fi, 18 LEER datos[ i ]

      i <- i + 1

   FINMIENTRAS

   Borrar_pantalla( )

   i <- 1

   fi <- 3

   EN 1,20 ESCRIBIR "Elementos de la lista"

   MIENTRAS i < 21 HACER

      EN fi,28 ESCRIBIR datos[ i ]

      fi <- fi + 1

      i <- i + 1

   FINMIENTRAS

FINPROGRAMA

 

--------------------------------------------------------------------------

 

34.-Hacer un programa que lea las calificaciones de un alumno en 10

asignaturas, las almacene en un vector y calcule e imprima su media.

 

PROGRAMA notamedia

ENTORNO:

   DIMENSIONA notas[ 10 ]

   suma <- 0

   media <- 0

ALGORITMO:

   Borrar_pantalla( )

   fi <- 7

   PARA i DESDE 1 HASTA 10 HACER

      EN fi,15 ESCRIBIR "Nota "

      EN fi,20 ESCRIBIR i

      EN fi,21 ESCRIBIR ": "

      EN fi,23 LEER notas[ i ]

      fi <- fi + 1

   FINPARA

   PARA i DESDE 1 HASTA 10 HACER

      suma <- suma + notas[ i ]

   FINPARA

   media <- suma / 10

   EN 20,20 ESCRIBIR "Nota media: "

   EN 20,32 ESCRIBIR media

FINPROGRAMA

 

--------------------------------------------------------------------------

 

35.-Usando el segundo ejemplo, hacer un programa que busque una nota en el

vector.

 

PROGRAMA buscar

ENTORNO:

   i <- 0

   num <- 0

ALGORITMO:

   Borrar_pantalla( )

   ESCRIBIR "Nota a buscar: "

   LEER num

   ITERAR

      i <- i + 1

      SI notas[ i ] = num O i = 10 ENTONCES

         SALIR

      FINSI

   FINITERAR

   SI notas[ i ] = num ENTONCES

      ESCRIBIR "Encontrado en posici&oacute;n: "

      ESCRIBIR i

   SINO

      ESCRIBIR "No existe esa nota"

   FINSI

FINPROGRAMA

 

--------------------------------------------------------------------------

TEMA 5

--------------------------------------------------------------------------

Arrays bidimensionales

--------------------------------------------------------------------------

 

36.-Generar una matriz de 4 filas y 5 columnas con numeros aleatorios entre 1

y 100, e imprimirla.

 

PROGRAMA matriz

ENTORNO:

   DIMENSIONAR A[ 4, 5 ]

   i <- 1

   fi <- 10

   co <- 15<

{
}
{
}

Comentarios 52 EJERCICIOS pseudocódigo! RESUELTOS... - página 2

enconte buenos ejercios meayudaron vastante
muchascracias
ruben alvarez ruben alvarez 15/11/2010 a las 15:59
Hola, favor alguien me podria ayudar a realizar este ejercicio:
Diseñar un algoritmo, en pseudocódigo, de un programa que permita ingresar un conjunto de datos numéricos y a continuación calcule y muestre los siguientes estadísticos: suma, promedio, dato mayor, dato menor y número de datos ingresados.
El programa deberá preguntar, luego de cada dato numérico ingresado, si ya termino con el ingreso de datos para proceder a mostrar los estadísticos solicitados.
Eduardo Cordova Eduardo Cordova 27/01/2011 a las 17:52
el algoritmo numero 10 es incorrecto porque cuando corro el programa doy como dato de entrada un 5 y me lo lee como par porfavor podrias arreglarlo xD
gilberto gilberto 01/03/2011 a las 02:10
Gilberto el ejercicio no está incorrecto... Si te pones a pensar un ratito y sabés algo de programación te darás cuenta que al poner int(num/2) el resultado es entero, es decir que 5/2 daría 2 como resultado y ese 2 multiplicado por 2 es 4 y 4 NO es igual a 5 por eso es IMPAR ! Es imposible q te halla dado mal porque la única forma de q te de mal es si no pones el int() y haces sólo el 5/2 , o sea daría 2.5 y eso por 2 es 5 y 5 es igual a 5 por eso te tira que es par ! En fin, el ejercicio esta bien hecho y te agradecería que te fijes bien antes de comentar porque podés confundir a otros . Muchas gracias
ME AYUDAN CON ESTO POR FAVOR...
el Dr. Luis castillo es un medico cardiologo de adultos, que posee un consultorio donde atiende gran cantidad de pacientes, de cada uno de ellos se desea almacenar: cedula, nombre, apellido, sexo, direccion, telefono, fecha de nacimiento, los cuales se encuentran asociado apuntando solo al paciente que viene despues de el. para cada paciente se registran cada una de las consultas que se realizan , en este sentido, se almacena: fecha de consulta, motivo de la misma, diagnostico realizado y tratamiento propuesto, estas se encuentran asociada de forma circular y enlazadas en ambos sentidos. para esto se desea realizar un algoritmo en pseudocodigo orientado a objetos y su implementacion en java que permita:
insertar una nueva consulta a un paciente determinado. debe tomar en cuenta que cada vez que se inserte alguna se debe ordenar la lista de forma descendente deacuerdo a la cedula.eliminar a un paciente deacuerdo a su numero de cedula.determinar la ganancia total del doctor para un dia especifico ( el usuario indica la fecha) sabiendo que cada consulta tiene un costo de 150,00 bs.
*mostrar los pacientes q han recibido como parte de su tratamiento caduet.
mariargenis mariargenis 27/03/2011 a las 06:19
1.   Realice el algoritmo para determinar cuántos dígitos tiene un número entero positivo o negativo ingresado por teclado.
2.   Pida por teclado el área de un círculo, luego pida al usuario cual sería el radio de ese círculo, imprima por teclado en cuanto porcentaje se equivocó el usuario, si es menos del 5% imprima "usted es una calculadora!!!", si es entre 5% y 20%, imprima "Bien, bien, no muy bien pero bien", si supera el 25% imprima "sería bueno que dejara tanta calculadora y practicara un poco a hacer cálculos mentales".
john fredy john fredy 27/03/2011 a las 21:11
necesito q me ayuden a resolver ste ejercicio:
-obtener la edad de una persona en meses, si se ingresa su edad en años.
en algoritmo y pseudocodigooo.!!!
ismael ismael 30/03/2011 a las 02:59
como puede realizar un pseudocodigo en pseint utilizando la sentencia swicth para determinar el dia de la semana
clau clau 02/04/2011 a las 04:45
ok a qui les dejo uno espero y les sirva alguna dia a mi me sirvio para mi examen jejjejejjejejejej

tiene como proceso "hacer un muestreo de todo esta gente" sale  que chido es to de programar la neta que si
sn<-0
sj<-0
sa<-0
sv<-0
para personas<-1 hasta 50 con paso 1 Hacer
Escribir "Teclee la edad de la persona ",personas
Leer e
            Escribir "Teclee el peso de la persona ",personas
Leer p
si e>0 y e<=12 Entonces
                  sn<-sn+1
Sino
                  si e>12 y e<=29 Entonces
                        sj<-sj+1
Sino
                        si e>29 y e<=59 Entonces
                             sa<-sa+1
Sino
                             sv<-sv+1
FinSi
                  FinSi
            FinSi
      Finpara
      promni<-50/sn
promjov<-50/sj
promadult<-50/sa
promvet<-50/sv
Escribir "El peso promedio en los niños es de ",promni
Escribir "El peso promedio en los jovenes es de ",promjov
Escribir "El peso promedio en los adultos es de ",promadult
Escribir "El peso promedio en los veteranos es de ",promvet
luis alfredo luis alfredo 14/04/2011 a las 20:52
excelente aporte me sirvio mucho estos algoritmos muchas gracias...xd
peter peter 15/04/2011 a las 19:31
Hola me gustaría saber cuál seria el pseudocódigo para lo siguiente:
Imprimir n veces números primos o
Imprimir n veces los números primos
Espero pronta respuesta, muchas gracias.
No se si cuando respondan me llegara notificación a mi correo 
Luis Alberto Luis Alberto 29/04/2011 a las 17:57
hola me podrian decir la respuesta del siguiente pseudocodigo:
Elaborar un pseudocodigo que al introducir un numero por teclado nos diga si es positivo o negativo :-D :-(
lety lety 04/05/2011 a las 17:01
Estan muy buenos los ejercicios me alegra que ayuden a los que lo necesitamos. gracias


mario stuart mario stuart 31/05/2011 a las 02:12
Se requiere de un programa que permita  el ingreso de las calificaciones de una evaluación del curso de programación. El número de calificaciones  se desconoce, por lo que el usuario  deberá indicar cuando ya no desee  ingresar más datos. Su algoritmo debe contar las notas de acuerdo a la siguiente clasificación:
INSUFICIENTE                         Si nota < 50
REGULAR                               Si nota >= 50 y < 60
BIEN                                       Si nota >= 60 y < 70
MUY BIEN                              Si nota >= 70 y < 90
SOBRESALIENTE                     Si nota >= 90
Al finalizar el ingreso de datos, debe aparecer el número de alumnos que están en cada grupo de notas.
mario stuart mario stuart 31/05/2011 a las 19:19
elaborar un programa que genere 100 numeros aleatorios entre 1-100 y que determine el promedio
de aquellos que son pares , el promedio de aquellos que son impares y calcule la suma de los numeros
primos ( programar en pseint en c mas mas )
antonio antonio 05/06/2011 a las 08:47
Hola quien sabra hacer este Pseudocodigo
realizar un Pseudocodigo donde se introduzcan 2 numeros por teclado que imprima los numeros naturales que hay entre ambo numeros, empezando por el mas pequeno y contar cuanto hay.
gracias por la ayuda que puedan ofrecer

Richard Richard 06/06/2011 a las 00:55
Definir un vector a de 50 posiciones y almacenar en el valores enteros pero solo en las posiciones pares, luego llevar en el segundo vector b de 50 posiciones y llevar con valores enteros solo los impares. Por último generar un 3 vector de 25 posiciones el cual guardara la multiplicación de una posición par con una posición impar, al final mostrar todos los valores contenidos en el 3 vector.
jhoel jhoel 04/07/2011 a las 00:52
nececito un pseudocodigo para este problema.
Una empresa cuenta con10 productos las cuales estan codificados del 1 al 10 y con 3 almacenes los cuales estan condificados del 1 ql 3.
Cada vez que se realiza un pedido de un producto a un alamacen se registra los siguientes datos.
codigo de producto, codigo de alamacen, cantidad de almacen, cantidad de unidades solicitadas.
El ingreso de datos termina cuando el usuario lo decida, luego de cual se debera presentar el siguiente reporte estadistico:
A) Cantidad de unidades solicitadas por producto.
b)Cantidad de unidades solicitadas por alamacen.
c) Almacenes o almacenes con la mayor cantidad de productos solicitados.
d)Mostrar la cantidad de productos solicitados por producto y alamacen.
e)Mostrar la cantidad de solicitudes realizadas.
thanks you espero sus respuestas...
JAVIER JAVIER 19/08/2011 a las 16:18
la verda wenisimo estan los ejercicios
fernando fernando 31/08/2011 a las 00:10
Hola todos xikos xD
estan buenos los ejercicios.. me gustaria ke me ayudaran n una kosa
kisiera sabes algun metodo exelent para obtener el cociente d una division sea int A y B y Cpodria ser double
pero sin utilizar el Div ni el Mod obtener el cociente y el residuo ando asiendo eso xD
gracias y les deseo muxa suerte en sus proyectos ^^!
necesito que me ayuden a resolber esto porfa...
realizar en pseudocodigo un programa que calcule de forma individual la velocidad de 5 cuerpos, introduciendo por teclado el espacio y el tiempo, hallando posteriormente la media de cada una de la tres magnitudes.
Juan93 Juan93 12/09/2011 a las 01:46
gracias; el aporte es muy valioso
gabriel gabriel 16/09/2011 a las 20:05
Contar cuantas veces aparecen los ceros en una serie de numeros dados
quisiera q me puedan ayudar a resolver este ejercicio con metodos y objetos
encontrar la suma  de digitos de un numero q me de el usuario por ejemplo
543=5+4+3=12
gabriel gabriel 05/11/2011 a las 22:31
Como se resuelve estos problema? Ayudenme por favor.

Cuadrado Latino.
Un cuadrado latino de orden N es una matriz cuadrada que en su primera fila contiene los
N primeros números naturales y en cada una de las siguientes filas contiene la rotación de la
fila anterior, un lugar a la derecha. Construya una solución algorítmica que permita generar
el cuadrado latino de orden N.
Cuadrado mágico.
Un cuadrado mágico es una matriz compuesta de valores enteros tales que los elementos de las
filas, columnas y diagonales principales suman el mismo número. El algoritmo para generar
el cuadrado mágico de una matriz de orden impar es el siguiente:
-      Coloque el número 1 en la primera fila, posición del centro.
-      Coloque el número siguiente en la casilla correspondiente a la fila anterior y columna posterior.
-      Si el número a colocar es el que sigue a un múltiplo de N, no se aplica la regla anterior, sino que éste se coloca en la casilla de la fila posterior, misma columna.
Se considera que la fila anterior a la primera es la última y que la columna posterior a la última es la primera.
Construya una solución algorítmica que permita generar el cuadrado mágico de orden N.

Leer dos vectores desordenados A y B de reales de dimensión N. Escribir un programa que cree un vector C de dimensión 2 x n que contenga todas las componentes de A y B ordenadas de menor a mayor, teniendo en cuenta que:
•Los vectores A y B no se pueden modificar.
•No se puede aplicar ningún método de ordenación a C.
•Si se introduce un elemento en C, éste no podrá ser movido de esa posición.
•No usar vectores auxiliares de reales.
•Suponer que ni en A ni en B hay elementos repetidos.
sergio sergio 26/11/2011 a las 20:35
yo quiero saber como hacer para que un numero decimal que introducimos por teclado se convierta a numero binario
jorge jorge 30/11/2011 a las 22:22
En el blog no se realizan ejercicios pero si se brinda una ayuda a las consultas que sean pertinentes y específicas. JORGE: para convertir un numero de decimal a binario tenes que ingresar un numero (N) por teclado y mediante un ciclo while que finaliza cuando el resultado de la division es 0. El resultado va a ser la acumulacion de los restos de la division por dos comenzando de la ultima.
Ej:
14/2 . 7  resto 0
7 /2. resto 1 (3.5)
3 (porque toma solo la parte entera ) /2 resto 1
1/2 resto 1
termina porque el resultado llego a 0 . (0/2)
* 14 en binario es 1110
Espero te haya servido...
hola ..estaría bueno que los ejercicos que van preguntando sean visibles para todos ya que son similares y creo   a que a todos nos sería de gran ayuda- buenísmo ! 
marce marce 05/12/2011 a las 05:17
hola queria saber si me pueden enviar los demas ejercicios propuestos a partir del 36 al 52 xq ya no stan
agradeceria su respuesta
Ronny Ronny 24/01/2012 a las 00:41
sera que me pueden ayudar a resolver este algoritmo por favor lo necesto urgente
1)hacer un seudocodigo  que permita leer un numero entero positivo  que sea moyor de 35 y que atraves de una funcion calcular su factorial.
2)procedimiento que recibe como dato de entrada de dos numeros enteros y devolver el cubo del primer numero y la raiz cuadrada del primero para el segundo.
se lo agradeceria
dayana dayana 23/02/2012 a las 22:04

Deja tu comentario 52 EJERCICIOS pseudocódigo! RESUELTOS...

Identifícate en OboLog, o crea tu blog gratis si aún no estás registrado.

Avatar de usuario Tu nombre